CRAN Package Check Results for Package novelforestSG

Last updated on 2021-06-22 23:50:40 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.2.1 1.86 34.22 36.08 OK
r-devel-linux-x86_64-debian-gcc 1.2.1 1.37 26.76 28.13 OK
r-devel-linux-x86_64-fedora-clang 1.2.1 51.86 OK
r-devel-linux-x86_64-fedora-gcc 1.2.1 42.13 OK
r-devel-windows-x86_64 1.2.1 4.00 50.00 54.00 OK
r-devel-windows-x86_64-gcc10-UCRT 1.2.1 ERROR
r-patched-linux-x86_64 1.2.1 1.89 34.16 36.05 OK
r-patched-solaris-x86 1.2.1 69.30 OK
r-release-linux-x86_64 1.2.1 1.69 33.63 35.32 OK
r-release-macos-arm64 1.2.1 OK
r-release-macos-x86_64 1.2.1 OK
r-release-windows-ix86+x86_64 1.2.1 5.00 43.00 48.00 OK
r-oldrel-macos-x86_64 1.2.1 OK

Check Details

Version: 1.2.1
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: 'brms'
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 1.2.1
Check: examples
Result: ERROR
    Running examples in 'novelforestSG-Ex.R' failed
    The error most likely occurred in:
    
    > ### Name: download_model
    > ### Title: Download Model Fitted to the 'novelforest' Data
    > ### Aliases: download_model
    >
    > ### ** Examples
    >
    > novelforest_model <- download_model()
    To save the model locally, use argument save_to = 'path/filename.rds'
    Downloading model (size: 16.5 Mb)
    >
    > # library(brms) # recommended
    > summary(novelforest_model)
    Loading required package: rstan
    Warning in library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
     there is no package called 'rstan'
    Error in .requirePackage(package) :
     unable to find required package 'rstan'
    Calls: summary ... .extendsForS3 -> extends -> getClassDef -> .requirePackage
    Execution halted
Flavor: r-devel-windows-x86_64-gcc10-UCRT