CRAN Package Check Results for Package Plasmidprofiler

Last updated on 2021-06-24 10:52:33 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.1.6 6.29 69.56 75.85 NOTE
r-devel-linux-x86_64-debian-gcc 0.1.6 5.32 52.38 57.70 NOTE
r-devel-linux-x86_64-fedora-clang 0.1.6 99.32 NOTE
r-devel-linux-x86_64-fedora-gcc 0.1.6 84.40 ERROR
r-devel-windows-x86_64 0.1.6 11.00 93.00 104.00 OK
r-devel-windows-x86_64-gcc10-UCRT 0.1.6 ERROR
r-patched-linux-x86_64 0.1.6 7.22 65.93 73.15 NOTE
r-patched-solaris-x86 0.1.6 116.30 NOTE
r-release-linux-x86_64 0.1.6 6.58 65.07 71.65 NOTE
r-release-macos-arm64 0.1.6 OK
r-release-macos-x86_64 0.1.6 OK
r-release-windows-ix86+x86_64 0.1.6 13.00 70.00 83.00 OK
r-oldrel-macos-x86_64 0.1.6 OK

Additional issues

M1mac

Check Details

Version: 0.1.6
Check: for non-standard things in the check directory
Result: NOTE
    Found the following files/directories:
     'P2Run.csv' 'P2Run.html' 'P2Run.png'
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-patched-linux-x86_64, r-release-linux-x86_64

Version: 0.1.6
Check: examples
Result: ERROR
    Running examples in ‘Plasmidprofiler-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: main
    > ### Title: Main: Run everything
    > ### Aliases: main
    >
    > ### ** Examples
    >
    > main(blastdata,
    + srst2data,
    + coverage.filter=NA,
    + sureness.filter=0.75,
    + length.filter=10000,
    + main.title="Example Results")
    Selecting by pident
    Warning: `data_frame()` was deprecated in tibble 1.1.0.
    Please use `tibble()` instead.
    This warning is displayed once every 8 hours.
    Call `lifecycle::last_warnings()` to see where this warning was generated.
    Warning: Vectorized input to `element_text()` is not officially supported.
    Results may be unexpected or may change in future versions of ggplot2.
    Saving 12 x 7 in image
    Error in png_dev(..., res = dpi, units = "in") :
     unused argument (type = "cairo")
    Calls: main -> save_files -> ggsave -> dev
    Execution halted
Flavor: r-devel-linux-x86_64-fedora-gcc

Version: 0.1.6
Check: package dependencies
Result: ERROR
    Package required but not available: 'plotly'
    
    Package suggested but not available for checking: 'lintr'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 0.1.6
Check: for non-standard things in the check directory
Result: NOTE
    Found the following files/directories:
     ‘P2Run.csv’ ‘P2Run.png’
Flavor: r-patched-solaris-x86